Q
We use the integers , , and to create the following series:
You are given queries in the form of , , and . For each query, print the series corresponding to the given , , and values as a single line of space-separated integers.
Input Format
The first line contains an integer, , denoting the number of queries.
Each line of the subsequent lines contains three space-separated integers describing the respective , , and values for that query.
Constraints
Output Format
For each query, print the corresponding series on a new line. Each series must be printed in order as a single line of space-separated integers.
Sample Input
2
0 2 10
5 3 5
Sample Output
2 6 14 30 62 126 254 510 1022 2046
8 14 26 50 98
Explanation
We have two queries:
- We use , , and to produce some series :
- Once we hit , we print the first ten terms as a single line of space-separated integers.
- We use , , and to produce some series :
A
import java.util.*;
import java.io.*;
class Solution{
public static void main(String []argh){
Scanner in = new Scanner(System.in);
int t=in.nextInt();
for(int i=0;i<t;i++){
StringBuilder sb = new StringBuilder();
int a = in.nextInt();
int b = in.nextInt();
int n = in.nextInt();
for(int j=0; j<n; ++j) {
sb.append((int) (a + b * (Math.pow(2, j+1) - 1))).append(" ");
}
System.out.println(sb.toString());
}
in.close();
}
}
'Algorithm > Algorithm__hackerrank-Java' 카테고리의 다른 글
Currency Formatter (0) | 2022.06.21 |
---|---|
Date And Time (0) | 2022.06.21 |
End-of-file (0) | 2022.06.21 |
Introduction - Java Datatypes (0) | 2022.06.21 |
Introduction - Java Output Formatting (0) | 2022.06.21 |